CVE-2015-2269: Moodle XSS Vulnerability
Moodle XSS Vulnerability
Other sources
Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.
— GitHub
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.8.4 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.7.6 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.6.9
Event History
Frequently Asked Questions
What is the severity of CVE-2015-2269?
CVE-2015-2269 is considered a medium severity vulnerability due to its potential for remote authenticated XSS attacks.
How do I fix CVE-2015-2269?
To resolve CVE-2015-2269, upgrade Moodle to version 2.6.9, 2.7.6, or 2.8.4 or later.
Which versions of Moodle are affected by CVE-2015-2269?
CVE-2015-2269 affects Moodle versions 2.5.9 and earlier, all 2.6.x versions before 2.6.9, all 2.7.x versions before 2.7.6, and all 2.8.x versions before 2.8.4.
What types of attacks can be performed due to CVE-2015-2269?
CVE-2015-2269 can allow remote authenticated users to inject arbitrary web scripts or HTML through the alt or title attributes in IMG elements.
How can I determine if my Moodle installation is vulnerable to CVE-2015-2269?
You can determine if your Moodle installation is vulnerable to CVE-2015-2269 by checking the version number against the affected versions listed.