CVE-2015-2271: Moodle does not consider the moodle/tag:flag capability

Published Jun 1, 2015
·
Updated

Moodle does not consider the moodle/tag:flag capability

Other sources

tag/user.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 does not consider the moodle/tag:flag capability before proceeding with a flaginappropriate action, which allows remote authenticated users to bypass intended access restrictions via the "Flag as inappropriate" feature.

— GitHub

Affected Software

35 affected componentsFixes available
composer/moodle/moodle>=2.8.0<2.8.4
2.8.4
composer/moodle/moodle>=2.7.0<2.7.6
2.7.6
composer/moodle/moodle<2.6.9
2.6.9
Moodle Moodle<=2.5.9
Moodle Moodle=2.5.0
Moodle Moodle=2.5.1
Moodle Moodle=2.5.2
Moodle Moodle=2.5.3
Moodle Moodle=2.5.4
Moodle Moodle=2.5.5
Moodle Moodle=2.5.6
Moodle Moodle=2.5.7
Moodle Moodle=2.5.8
Moodle Moodle=2.6.0
Moodle Moodle=2.6.1
Moodle Moodle=2.6.2
Moodle Moodle=2.6.3
Moodle Moodle=2.6.4
Moodle Moodle=2.6.5
Moodle Moodle=2.6.6
Moodle Moodle=2.6.7
Moodle Moodle=2.6.8
Moodle Moodle=2.7.0
Moodle Moodle=2.7.1
Moodle Moodle=2.7.2
Moodle Moodle=2.7.3
Moodle Moodle=2.7.4
Moodle Moodle=2.7.5
Moodle Moodle=2.8.0
Moodle Moodle=2.8.1
Moodle Moodle=2.8.2
Moodle Moodle=2.8.3
composer/moodle/moodle>=2.8.0, <2.8.4
2.8.4
composer/moodle/moodle>=2.7.0, <2.7.6
2.7.6
composer/moodle/moodle<2.6.9
2.6.9

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.8.4
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.7.6
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.6.9
  4. Upgrade

    Upgrade Moodle to a version that resolves this vulnerability.

    Fixed in 2.6.9
  5. Upgrade

    Upgrade Moodle to a version that resolves this vulnerability.

    Fixed in 2.7.6
  6. Upgrade

    Upgrade Moodle to a version that resolves this vulnerability.

    Fixed in 2.8.4

Event History

Jun 1, 2015
CVE Published
via MITRE·07:00 PM
Data Sourced
via MITRE·07:00 PM
Description
Data Sourced
via NVD·07:59 PM
DescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2015-2271?

CVE-2015-2271 has a medium severity level as it allows authenticated users to bypass access restrictions.

2

How do I fix CVE-2015-2271?

To fix CVE-2015-2271, upgrade Moodle to version 2.8.4, 2.7.6, or 2.6.9 or later.

3

What versions are affected by CVE-2015-2271?

CVE-2015-2271 affects Moodle versions 2.5.9 and earlier, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4.

4

What capability is not considered in CVE-2015-2271?

CVE-2015-2271 does not consider the moodle/tag:flag capability before flagging inappropriate actions.

5

Who is impacted by the vulnerability CVE-2015-2271?

Remote authenticated users of Moodle can exploit CVE-2015-2271 to bypass intended access restrictions.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203