CVE-2015-3181: Moodle allows attackers to bypass file-management restrictions

Published Jun 1, 2015
·
Updated

files/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 does not consider the moodle/user:manageownfiles capability before approving a private-file upload, which allows remote authenticated users to bypass intended file-management restrictions by using web services to perform uploads after this capability has been revoked.

Other sources

Moodle allows attackers to bypass file-management restrictions

— Packagist

Affected Software

41 affected componentsFixes available
composer/moodle/moodle>=2.8.0<2.8.6
2.8.6
composer/moodle/moodle>=2.7.0<2.7.8
2.7.8
composer/moodle/moodle<2.6.11
2.6.11
Moodle Moodle<=2.5.9
Moodle Moodle=2.5.0
Moodle Moodle=2.5.1
Moodle Moodle=2.5.2
Moodle Moodle=2.5.3
Moodle Moodle=2.5.4
Moodle Moodle=2.5.5
Moodle Moodle=2.5.6
Moodle Moodle=2.5.7
Moodle Moodle=2.5.8
Moodle Moodle=2.6.0
Moodle Moodle=2.6.1
Moodle Moodle=2.6.2
Moodle Moodle=2.6.3
Moodle Moodle=2.6.4
Moodle Moodle=2.6.5
Moodle Moodle=2.6.6
Moodle Moodle=2.6.7
Moodle Moodle=2.6.8
Moodle Moodle=2.6.9
Moodle Moodle=2.6.10
Moodle Moodle=2.7.0
Moodle Moodle=2.7.1
Moodle Moodle=2.7.2
Moodle Moodle=2.7.3
Moodle Moodle=2.7.4
Moodle Moodle=2.7.5
Moodle Moodle=2.7.6
Moodle Moodle=2.7.7
Moodle Moodle=2.8.0
Moodle Moodle=2.8.1
Moodle Moodle=2.8.2
Moodle Moodle=2.8.3
Moodle Moodle=2.8.4
Moodle Moodle=2.8.5
composer/moodle/moodle>=2.8.0, <2.8.6
2.8.6
composer/moodle/moodle>=2.7.0, <2.7.8
2.7.8
composer/moodle/moodle<2.6.11
2.6.11

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.8.6
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.7.8
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.6.11
  4. Upgrade

    Upgrade Moodle to a version that resolves this vulnerability.

    Fixed in 2.6.11
  5. Upgrade

    Upgrade Moodle to a version that resolves this vulnerability.

    Fixed in 2.7.8
  6. Upgrade

    Upgrade Moodle to a version that resolves this vulnerability.

    Fixed in 2.8.6

Event History

Jun 1, 2015
CVE Published
via MITRE·07:00 PM
Data Sourced
via MITRE·07:00 PM
Description
Data Sourced
via NVD·07:59 PM
DescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2015-3181?

CVE-2015-3181 has been classified as a medium severity vulnerability.

2

How do I fix CVE-2015-3181?

To fix CVE-2015-3181, upgrade to Moodle version 2.6.11, 2.7.8, or 2.8.6 and above.

3

Who is affected by CVE-2015-3181?

CVE-2015-3181 affects users of Moodle versions 2.5.0 to 2.8.5.

4

What type of vulnerability is CVE-2015-3181?

CVE-2015-3181 is a file management issue that allows bypassing intended upload restrictions.

5

Can CVE-2015-3181 be exploited remotely?

Yes, CVE-2015-3181 can be exploited by remote authenticated users.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203