CVE-2015-3337: Path Traversal
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Elasticsearchto a version that resolves this vulnerability.Fixed in 1.4.5 - Upgrade
Upgrade
Elasticsearchto a version that resolves this vulnerability.Fixed in 1.5.2
Event History
Frequently Asked Questions
What is the severity of CVE-2015-3337?
CVE-2015-3337 is classified as a medium severity vulnerability that allows remote attackers to exploit directory traversal.
What versions are affected by CVE-2015-3337?
CVE-2015-3337 affects Elasticsearch versions before 1.4.5 and version 1.5.0 to 1.5.1.
How do I fix CVE-2015-3337?
To fix CVE-2015-3337, upgrade Elasticsearch to version 1.4.5 or 1.5.2 and later.
What type of attack does CVE-2015-3337 enable?
CVE-2015-3337 enables remote attackers to read arbitrary files on the server via directory traversal.
Is CVE-2015-3337 related to site plugins in Elasticsearch?
Yes, CVE-2015-3337 specifically affects Elasticsearch when a site plugin is enabled.