CVE-2015-5269: Moodle cross-site scripting (XSS) vulnerability

Published Feb 22, 2016
·
Updated

Cross-site scripting (XSS) vulnerability in group/overview.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to inject arbitrary web script or HTML via a modified grouping description.

Other sources

Moodle cross-site scripting (XSS) vulnerability

— Packagist

Affected Software

27 affected componentsFixes available
composer/moodle/moodle>=2.9.0<2.9.2
2.9.2
composer/moodle/moodle>=2.8.0<2.8.8
2.8.8
composer/moodle/moodle<2.7.10
2.7.10
Moodle Moodle<=2.6.11
Moodle Moodle=2.7.0
Moodle Moodle=2.7.1
Moodle Moodle=2.7.2
Moodle Moodle=2.7.3
Moodle Moodle=2.7.4
Moodle Moodle=2.7.5
Moodle Moodle=2.7.6
Moodle Moodle=2.7.7
Moodle Moodle=2.7.8
Moodle Moodle=2.7.9
Moodle Moodle=2.8.0
Moodle Moodle=2.8.1
Moodle Moodle=2.8.2
Moodle Moodle=2.8.3
Moodle Moodle=2.8.4
Moodle Moodle=2.8.5
Moodle Moodle=2.8.6
Moodle Moodle=2.8.7
Moodle Moodle=2.9.0
Moodle Moodle=2.9.1
composer/moodle/moodle>=2.9.0, <2.9.2
2.9.2
composer/moodle/moodle>=2.8.0, <2.8.8
2.8.8
composer/moodle/moodle<2.7.10
2.7.10

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.9.2
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.8.8
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.7.10

Event History

Feb 22, 2016
CVE Published
via MITRE·02:00 AM
Data Sourced
via MITRE·02:00 AM
Description
Data Sourced
via NVD·05:59 AM
DescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via GitHub·01:12 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2015-5269?

CVE-2015-5269 has a moderate severity rating due to its potential for cross-site scripting attacks.

2

How do I fix CVE-2015-5269?

To fix CVE-2015-5269, upgrade Moodle to version 2.7.10, 2.8.8, or 2.9.2 or later.

3

Who is affected by CVE-2015-5269?

CVE-2015-5269 affects users of Moodle versions prior to 2.7.10, 2.8.8, and 2.9.2.

4

What kind of vulnerability is CVE-2015-5269?

CVE-2015-5269 is a cross-site scripting (XSS) vulnerability that allows authenticated users to inject malicious scripts.

5

Can CVE-2015-5269 impact my Moodle site?

Yes, CVE-2015-5269 can impact Moodle sites by allowing attackers to execute arbitrary scripts in the context of users' sessions.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203