CVE-2015-5342: Moodle allows attackers to bypass intended access restrictions

Published Feb 22, 2016
·
Updated

Moodle allows attackers to bypass intended access restrictions

Other sources

The choice module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allows remote authenticated users to bypass intended access restrictions by visiting a URL to add or delete responses in the closed state.

— GitHub

Affected Software

30 affected componentsFixes available
composer/moodle/moodle>=2.9.0<2.9.3
2.9.3
composer/moodle/moodle>=2.8.0<2.8.9
2.8.9
composer/moodle/moodle<2.7.11
2.7.11
Moodle Moodle<=2.6.11
Moodle Moodle=2.7.0
Moodle Moodle=2.7.1
Moodle Moodle=2.7.2
Moodle Moodle=2.7.3
Moodle Moodle=2.7.4
Moodle Moodle=2.7.5
Moodle Moodle=2.7.6
Moodle Moodle=2.7.7
Moodle Moodle=2.7.8
Moodle Moodle=2.7.9
Moodle Moodle=2.7.10
Moodle Moodle=2.8.0
Moodle Moodle=2.8.1
Moodle Moodle=2.8.2
Moodle Moodle=2.8.3
Moodle Moodle=2.8.4
Moodle Moodle=2.8.5
Moodle Moodle=2.8.6
Moodle Moodle=2.8.7
Moodle Moodle=2.8.8
Moodle Moodle=2.9.0
Moodle Moodle=2.9.1
Moodle Moodle=2.9.2
composer/moodle/moodle>=2.9.0, <2.9.3
2.9.3
composer/moodle/moodle>=2.8.0, <2.8.9
2.8.9
composer/moodle/moodle<2.7.11
2.7.11

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.9.3
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.8.9
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.7.11
  4. Upgrade

    Upgrade Moodle choice module to a version that resolves this vulnerability.

    Fixed in 2.7.11
  5. Upgrade

    Upgrade Moodle choice module to a version that resolves this vulnerability.

    Fixed in 2.8.9
  6. Upgrade

    Upgrade Moodle choice module to a version that resolves this vulnerability.

    Fixed in 2.9.3

Event History

Feb 22, 2016
CVE Published
via MITRE·02:00 AM
Data Sourced
via MITRE·02:00 AM
Description
Data Sourced
via NVD·05:59 AM
DescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via GitHub·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2015-5342?

CVE-2015-5342 is classified as a medium severity vulnerability.

2

How do I fix CVE-2015-5342?

To fix CVE-2015-5342, update your Moodle installation to versions 2.7.11, 2.8.9, or 2.9.3 and above.

3

What types of access restrictions are bypassed by CVE-2015-5342?

CVE-2015-5342 allows remote authenticated users to bypass access restrictions to add or delete responses in the closed state.

4

Which versions of Moodle are affected by CVE-2015-5342?

CVE-2015-5342 affects Moodle versions through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3.

5

What module in Moodle is vulnerable to CVE-2015-5342?

The choice module in Moodle is vulnerable to CVE-2015-5342.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203