CVE-2016-0705: Double Free

Published Feb 22, 2016
·
Updated

As per Upstream advisory:

A double free bug was discovered when OpenSSL parses malformed DSA private keys and could lead to a DoS attack or memory corruption for applications that receive DSA private keys from untrusted sources. This scenario is considered rare.

This issue affects OpenSSL versions 1.0.2 and 1.0.1.

OpenSSL 1.0.2 users should upgrade to 1.0.2g OpenSSL 1.0.1 users should upgrade to 1.0.1s

This issue was reported to OpenSSL on 7th February 2016 by Adam Langley (Google/BoringSSL) using libFuzzer. The fix was developed by Dr Stephen Henson of OpenSSL.

Other sources

Double free vulnerability in the dsaprivdecode function in crypto/dsa/dsaameth.c in OpenSSL 1.0.1 before 1.0.1s and 1.0.2 before 1.0.2g allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a malformed DSA private key.

— MITRE

Affected Software

66 affected componentsFixes available
Oracle MySQL>=5.6.0<=5.6.29
Oracle MySQL>=5.7.0<=5.7.11
OpenSSL OpenSSL=1.0.1
OpenSSL OpenSSL=1.0.1-beta1
OpenSSL OpenSSL=1.0.1-beta2
OpenSSL OpenSSL=1.0.1-beta3
OpenSSL OpenSSL=1.0.1a
OpenSSL OpenSSL=1.0.1b
OpenSSL OpenSSL=1.0.1c
OpenSSL OpenSSL=1.0.1d
OpenSSL OpenSSL=1.0.1e
OpenSSL OpenSSL=1.0.1f
OpenSSL OpenSSL=1.0.1g
OpenSSL OpenSSL=1.0.1h
OpenSSL OpenSSL=1.0.1i
OpenSSL OpenSSL=1.0.1j
OpenSSL OpenSSL=1.0.1k
OpenSSL OpenSSL=1.0.1l
OpenSSL OpenSSL=1.0.1m
OpenSSL OpenSSL=1.0.1n
OpenSSL OpenSSL=1.0.1o
OpenSSL OpenSSL=1.0.1p
OpenSSL OpenSSL=1.0.1q
OpenSSL OpenSSL=1.0.1r
OpenSSL OpenSSL=1.0.2
OpenSSL OpenSSL=1.0.2-beta1
OpenSSL OpenSSL=1.0.2-beta2
OpenSSL OpenSSL=1.0.2-beta3
OpenSSL OpenSSL=1.0.2a
OpenSSL OpenSSL=1.0.2b
OpenSSL OpenSSL=1.0.2c
OpenSSL OpenSSL=1.0.2d
OpenSSL OpenSSL=1.0.2e
OpenSSL OpenSSL=1.0.2f
Google Android=4.0
Google Android=4.0.1
Google Android=4.0.2
Google Android=4.0.3
Google Android=4.0.4
Google Android=4.1
Google Android=4.1.2
Google Android=4.2
Google Android=4.2.1
Google Android=4.2.2
Google Android=4.3
Google Android=4.3.1
Google Android=4.4
Google Android=4.4.1
Google Android=4.4.2
Google Android=4.4.3
Google Android=5.0
Google Android=5.0.1
Google Android=5.1
Google Android=5.1.0
Google Android=6.0
Google Android=6.0.1
Canonical Ubuntu Linux=12.04
Canonical Ubuntu Linux=14.04
Canonical Ubuntu Linux=15.10
Debian Debian Linux=7.0
Debian Debian Linux=8.0
redhat/openssl<1.0.1
1.0.1
redhat/openssl<1.0.2
1.0.2
Node.js Node.js>=4.0.0<4.3.2
4.3.2
Node.js Node.js>=5.0.0<5.7.1
5.7.1
Google Android

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/openssl to a version that resolves this vulnerability.

    Fixed in 1.0.1
  2. Upgrade

    Upgrade redhat/openssl to a version that resolves this vulnerability.

    Fixed in 1.0.2
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 4.3.2
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 5.7.1
  5. Upgrade

    Upgrade OpenSSL to a version that resolves this vulnerability.

    Fixed in 1.0.1s
  6. Upgrade

    Upgrade OpenSSL to a version that resolves this vulnerability.

    Fixed in 1.0.2g

Event History

Feb 22, 2016
Data Sourced
via Red Hat·10:31 AM
DescriptionSeverityAffected Software
Mar 2, 2016
CVE Published
via Node.js·09:53 PM
Data Sourced
via Node.js·09:53 PM
SeverityAffected Software
Mar 3, 2016
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
May 2, 2016
Data Sourced
via Android·12:00 AM
SeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2016-0705?

CVE-2016-0705 has a medium severity rating, allowing for potential denial of service (memory corruption).

2

How do I fix CVE-2016-0705?

To fix CVE-2016-0705, update OpenSSL to version 1.0.1s or later for 1.0.1 series or 1.0.2g or later for 1.0.2 series.

3

Which versions of OpenSSL are affected by CVE-2016-0705?

OpenSSL versions 1.0.1 before 1.0.1s and 1.0.2 before 1.0.2g are affected by CVE-2016-0705.

4

Can CVE-2016-0705 lead to data loss?

While CVE-2016-0705 primarily causes denial of service, it may potentially lead to data loss due to memory corruption.

5

Is CVE-2016-0705 exploitable remotely?

Yes, CVE-2016-0705 can be exploited by remote attackers through a malformed DSA private key.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203