CVE-2016-0724: Moodle sensitive information disclosure
Moodle sensitive information disclosure
Other sources
The (1) coreenrolgetcourseenrolmentmethods and (2) enrolselfgetinstanceinfo web services in Moodle through 2.6.11, 2.7.x before 2.7.12, 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 do not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to obtain sensitive information via a web-service request.
— GitHub
The (1) coreenrolgetcourseenrolmentmethods and (2) enrolselfgetinstanceinfo web services in Moodle through 2.6.11, 2.7.x before 2.7.12, 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 do not consider the moodle/course:viewhiddencourses capability, which allows remote authenticated users to obtain sensitive information via a web-service request.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 3.0.2 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.9.4 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.8.10 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.7.12
Event History
Frequently Asked Questions
What is the vulnerability severity of CVE-2016-0724?
CVE-2016-0724 has a medium severity rating due to its potential to allow unauthorized access to hidden courses.
How do I fix CVE-2016-0724?
To mitigate CVE-2016-0724, update Moodle to a version that includes the relevant security patches, specifically version 2.7.12 or later.
Which Moodle versions are affected by CVE-2016-0724?
CVE-2016-0724 affects Moodle versions up to 2.6.11, as well as various versions in the 2.7, 2.8, 2.9, and 3.0 series before their respective patched releases.
What are the potential impacts of CVE-2016-0724?
Exploitation of CVE-2016-0724 may allow users without the proper permissions to view hidden course content.
Is there a workaround for CVE-2016-0724 if I cannot update Moodle?
If updating is not immediately possible, restrict user access to the affected web services as a temporary mitigation for CVE-2016-0724.