CVE-2016-0725: Moodle Cross-site scripting (XSS) vulnerability in course management search

Published Feb 22, 2016
·
Updated

Cross-site scripting (XSS) vulnerability in the searchpagination function in course/classes/managementrenderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

Other sources

Moodle Cross-site scripting (XSS) vulnerability in course management search

— Packagist

Affected Software

24 affected componentsFixes available
composer/moodle/moodle>=3.0<3.0.2
3.0.2
composer/moodle/moodle>=2.9<2.9.4
2.9.4
composer/moodle/moodle>=2.8<2.8.10
2.8.10
Fedoraproject Fedora=22
Fedoraproject Fedora=23
Moodle Moodle=2.8.0
Moodle Moodle=2.8.1
Moodle Moodle=2.8.2
Moodle Moodle=2.8.3
Moodle Moodle=2.8.4
Moodle Moodle=2.8.5
Moodle Moodle=2.8.6
Moodle Moodle=2.8.7
Moodle Moodle=2.8.8
Moodle Moodle=2.8.9
Moodle Moodle=2.9.0
Moodle Moodle=2.9.1
Moodle Moodle=2.9.2
Moodle Moodle=2.9.3
Moodle Moodle=3.0.0
Moodle Moodle=3.0.1
composer/moodle/moodle>=3.0, <3.0.2
3.0.2
composer/moodle/moodle>=2.9, <2.9.4
2.9.4
composer/moodle/moodle>=2.8, <2.8.10
2.8.10

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 3.0.2
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.9.4
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.8.10

Event History

Feb 22, 2016
CVE Published
via MITRE·02:00 AM
Data Sourced
via MITRE·02:00 AM
Description
Data Sourced
via NVD·05:59 AM
DescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via GitHub·01:12 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2016-0725?

CVE-2016-0725 has been classified as a high severity cross-site scripting (XSS) vulnerability.

2

How do I fix CVE-2016-0725?

To fix CVE-2016-0725, upgrade Moodle to version 2.8.10, 2.9.4, or 3.0.2 or later.

3

Which versions of Moodle are affected by CVE-2016-0725?

CVE-2016-0725 affects Moodle versions 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2.

4

Can CVE-2016-0725 be exploited by remote attackers?

Yes, CVE-2016-0725 allows remote attackers to inject arbitrary web scripts or HTML via a crafted search string.

5

In which component of Moodle does CVE-2016-0725 occur?

CVE-2016-0725 occurs in the search_pagination function within course/classes/management_renderer.php.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203