CVE-2016-2040: phpMyAdmin XSS Vulnerability
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) table name, (2) SET value, (3) search query, or (4) hostname in a Location header.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.5.4 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.4.15.3 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.0.10.13
Event History
Frequently Asked Questions
What are the risks associated with CVE-2016-2040?
CVE-2016-2040 exposes phpMyAdmin to multiple cross-site scripting (XSS) vulnerabilities, allowing attackers to inject arbitrary web script or HTML.
How do I patch CVE-2016-2040?
To fix CVE-2016-2040, upgrade phpMyAdmin to at least version 4.5.4, 4.4.15.3, or 4.0.10.13.
Which versions of phpMyAdmin are affected by CVE-2016-2040?
CVE-2016-2040 affects phpMyAdmin versions 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4.
Who can exploit CVE-2016-2040?
CVE-2016-2040 can be exploited by remote authenticated users with sufficient privileges to change table names or modify search queries.
What is the potential impact of CVE-2016-2040?
The potential impact of CVE-2016-2040 includes unauthorized script execution in users' browsers, leading to data theft or session hijacking.