CVE-2016-2090: Buffer Overflow
Published Jan 13, 2017
·Updated
Last updated 25 August 2025
Other sources
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
— Launchpad
Affected Software
10 affected componentsFixes available
Fedoraproject Fedora=24
Fedoraproject Fedora=25
Freedesktop Libbsd<0.8.2
Debian Debian Linux=8.0
Canonical Ubuntu Linux=12.04
Canonical Ubuntu Linux=14.04
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=18.04
Canonical Ubuntu Linux=19.04
debian/libbsd
0.11.7-20.12.2-20.12.2-3
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/libbsdto a version that resolves this vulnerability.Fixed in 0.11.7-2Fixed in 0.12.2-2Fixed in 0.12.2-3
Event History
Jan 13, 2017
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·04:00 PM
Data Sourced
via MITRE·04:00 PM
Description
Data Sourced
via NVD·04:59 PM
RemedyDescriptionSeverityWeaknessAffected Software
Frequently Asked Questions
1
What is the vulnerability ID for this vulnerability?
The vulnerability ID is CVE-2016-2090.
2
What is the severity of CVE-2016-2090?
The severity of CVE-2016-2090 is critical with a CVSS score of 9.8.
3
What is the affected software for CVE-2016-2090?
The affected software for CVE-2016-2090 includes versions of libbsd before 0.8.2.
4
How does CVE-2016-2090 affect the software?
CVE-2016-2090 allows attackers to trigger a heap-based buffer overflow via unknown vectors, resulting in unspecified impact.
5
How can I fix CVE-2016-2090?
To fix CVE-2016-2090, update your software to version 0.8.2 or later of libbsd.