CVE-2016-2153: Moodle Reflected XSS in mod_data advanced search
Cross-site scripting (XSS) vulnerability in the advanced-search feature in moddata in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote attackers to inject arbitrary web script or HTML via a crafted field in a URL, as demonstrated by a search form field.
Other sources
Moodle Reflected XSS in moddata advanced search
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 3.0.3 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.9.5 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.8.11 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.7.13
Event History
Frequently Asked Questions
What is the severity of CVE-2016-2153?
CVE-2016-2153 is rated as a medium severity vulnerability due to its potential for cross-site scripting attacks.
How do I fix CVE-2016-2153?
To mitigate CVE-2016-2153, upgrade your Moodle installation to at least version 2.7.13, 2.8.11, 2.9.5, or 3.0.3.
What type of vulnerability is CVE-2016-2153?
CVE-2016-2153 is a cross-site scripting (XSS) vulnerability found in the advanced-search feature of Moodle.
Which versions of Moodle are affected by CVE-2016-2153?
CVE-2016-2153 affects Moodle versions from 2.6.11 up to, but not including, 2.7.13, 2.8.11, 2.9.5, and 3.0.3.
Can CVE-2016-2153 be exploited remotely?
Yes, CVE-2016-2153 can be exploited remotely by attackers to inject arbitrary web scripts or HTML into the application.