CVE-2016-2155: Moodle allows attackers to modify "Exclude grade" settings
Moodle allows attackers to modify "Exclude grade" settings
Other sources
The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.
— GitHub
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 3.0.3 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.9.5 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.8.11
Event History
Frequently Asked Questions
What is the severity of CVE-2016-2155?
CVE-2016-2155 is considered a medium-severity vulnerability due to its potential for unauthorized changes to grade settings.
How do I fix CVE-2016-2155?
To fix CVE-2016-2155, upgrade Moodle to version 2.8.11, 2.9.5, or 3.0.3 or higher.
What versions of Moodle are affected by CVE-2016-2155?
CVE-2016-2155 affects Moodle versions 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3.
What type of attack does CVE-2016-2155 enable?
CVE-2016-2155 allows remote authenticated users to potentially modify 'Exclude grade' settings without proper permissions.
Are there any workarounds for CVE-2016-2155?
While upgrading is the recommended solution for CVE-2016-2155, restricting user capabilities may mitigate some risks temporarily.