CVE-2016-2159: Moodle External function mod_assign_save_submission does not check due dates
Moodle External function modassignsavesubmission does not check due dates
Other sources
The savesubmission function in mod/assign/externallib.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote authenticated users to bypass intended due-date restrictions by leveraging the student role for a web-service request.
— GitHub
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 3.0.3 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.9.5 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.8.11 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.7.13 - Upgrade
Upgrade
Moodleto a version that resolves this vulnerability.Fixed in 2.7.13 - Upgrade
Upgrade
Moodleto a version that resolves this vulnerability.Fixed in 2.8.11 - Upgrade
Upgrade
Moodleto a version that resolves this vulnerability.Fixed in 2.9.5 - Upgrade
Upgrade
Moodleto a version that resolves this vulnerability.Fixed in 3.0.3
Event History
Frequently Asked Questions
What is the severity of CVE-2016-2159?
CVE-2016-2159 has been classified as a high severity vulnerability due to its potential to allow authenticated users to bypass due date restrictions.
How do I fix CVE-2016-2159?
To fix CVE-2016-2159, upgrade Moodle to version 2.7.13, 2.8.11, 2.9.5, or 3.0.3 or later.
Who is affected by CVE-2016-2159?
CVE-2016-2159 affects Moodle versions 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3.
What type of vulnerability is CVE-2016-2159?
CVE-2016-2159 is a permissions bypass vulnerability that allows authenticated users to interfere with assignment due dates.
Can CVE-2016-2159 be exploited remotely?
Yes, CVE-2016-2159 can be exploited remotely by authenticated users through specific web service requests.