CVE-2016-2216: Input Validation
Fix defects in HTTP header parsing for requests and responses that can allow response splitting (CVE-2016-2216).
HTTP header parsing now aligns more closely with the HTTP spec including restricting the acceptable characters.
Introduce new --security-revert={cvenum} command line flag for selective reversion of specific CVE fixes allow the fix for CVE-2016-2216 to be selectively reverted using --security-revert=CVE-2016-2216.
Other sources
The HTTP header parsing code in Node.js 0.10.x before 0.10.42, 0.11.6 through 0.11.16, 0.12.x before 0.12.10, 4.x before 4.3.0, and 5.x before 5.6.0 allows remote attackers to bypass an HTTP response-splitting protection mechanism via UTF-8 encoded Unicode characters in the HTTP header, as demonstrated by %c4%8d%c4%8a.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 4.3.0Fixed in 5.6.0 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 4.3.0 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 5.6.0 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 0.10.42Patch CVE-2016-2216 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 0.12.10Patch CVE-2016-2216 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 4.3.0Patch CVE-2016-2216 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 5.6.0Patch CVE-2016-2216
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2016-2216?
CVE-2016-2216 is considered a medium severity vulnerability due to its potential to bypass HTTP response-splitting protection mechanisms.
How do I fix CVE-2016-2216?
To fix CVE-2016-2216, upgrade your Node.js version to 0.10.42, 0.12.10, 4.3.0, or 5.6.0 or higher.
What versions of Node.js are affected by CVE-2016-2216?
CVE-2016-2216 affects Node.js versions 0.10.x before 0.10.42, 0.11.6 through 0.11.16, 0.12.x before 0.12.10, and earlier versions of 4.x and 5.x.
Can CVE-2016-2216 lead to more serious attacks?
Yes, CVE-2016-2216 could potentially allow attackers to manipulate HTTP headers, leading to further attacks like HTTP response splitting.
Is CVE-2016-2216 specific to certain operating systems?
CVE-2016-2216 primarily affects Node.js applications regardless of the operating system, but its impact may vary based on deployment environments.