CVE-2016-2329: Buffer Overflow
libavcodec/tiff.c in FFmpeg before 2.8.6 does not properly validate RowsPerStrip values and YCbCr chrominance subsampling factors, which allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via a crafted TIFF file, related to the tiffdecodetag and decodeframe functions.
Affected Software
Remediation
Event History
Frequently Asked Questions
What is the severity of CVE-2016-2329?
CVE-2016-2329 has been classified as a medium severity vulnerability that can lead to denial of service due to out-of-bounds array access.
How do I fix CVE-2016-2329?
To fix CVE-2016-2329, upgrade FFmpeg to version 2.8.6 or later.
What causes the issue described in CVE-2016-2329?
CVE-2016-2329 is caused by improper validation of RowsPerStrip values and YCbCr chrominance subsampling factors in TIFF files.
Is my system affected by CVE-2016-2329?
Systems running FFmpeg versions up to 2.8.5 or openSUSE Leap 42.1 are affected by CVE-2016-2329.
What type of attack does CVE-2016-2329 enable?
CVE-2016-2329 enables remote attackers to cause denial of service via a crafted TIFF file.