CVE-2016-2403: Unauthorized access on a misconfigured Ldap server when using an empty password
CVE-2016-2403: Unauthorized access on a misconfigured Ldap server when using an empty password
Other sources
Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/symfonyto a version that resolves this vulnerability.Fixed in 3.4.22+dfsg-2+deb10u1Fixed in 3.4.22+dfsg-2+deb10u2Fixed in 4.4.19+dfsg-2+deb11u3Fixed in 5.4.23+dfsg-1Fixed in 5.4.29+dfsg-1Fixed in 5.4.30+dfsg-1 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.0.6 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.8.6 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 3.0.6 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 2.8.6 - Upgrade
Upgrade
composer/symfony/security-coreto a version that resolves this vulnerability.Fixed in 3.0.6 - Upgrade
Upgrade
composer/symfony/security-coreto a version that resolves this vulnerability.Fixed in 2.8.6 - Upgrade
Upgrade
Symfonyto a version that resolves this vulnerability.Fixed in 2.8.6 - Upgrade
Upgrade
Symfonyto a version that resolves this vulnerability.Fixed in 3.0.6
Event History
Frequently Asked Questions
What is the severity of CVE-2016-2403?
CVE-2016-2403 is classified as a critical vulnerability due to its potential to allow unauthorized access.
How do I fix CVE-2016-2403?
To remediate CVE-2016-2403, upgrade Symfony to version 2.8.6 or 3.0.6 or later.
What versions are affected by CVE-2016-2403?
CVE-2016-2403 affects Symfony versions 2.8.0 through 2.8.6 and 3.0.0 through 3.0.6.
What kind of security risk does CVE-2016-2403 present?
CVE-2016-2403 presents a security risk of unauthorized access, allowing attackers to authenticate with empty passwords.
Is CVE-2016-2403 specific to any web framework?
Yes, CVE-2016-2403 specifically affects the Symfony framework versions mentioned.