CVE-2016-3109: Unauthenticated Remote Code Execution Vulnerability
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
Other sources
The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.
Unauthenticated Remote Code Execution Vulnerability
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/shopware/shopwareto a version that resolves this vulnerability.Fixed in 5.1.5 - Upgrade
Upgrade
composer/shopware/shopwareto a version that resolves this vulnerability.Fixed in 4.3.7
Event History
Frequently Asked Questions
What is the severity of CVE-2016-3109?
CVE-2016-3109 is rated as a high severity vulnerability due to its potential to allow unauthenticated remote code execution.
How do I fix CVE-2016-3109?
To fix CVE-2016-3109, upgrade Shopware to version 5.1.5 or later, or to version 4.3.7.
Who is affected by CVE-2016-3109?
CVE-2016-3109 affects Shopware versions before 5.1.5, specifically those in the 4.x and 5.0.x branches.
What type of vulnerability is CVE-2016-3109?
CVE-2016-3109 is classified as an unauthenticated remote code execution vulnerability.
Can CVE-2016-3109 be exploited remotely?
Yes, CVE-2016-3109 can be exploited remotely by attackers without authentication.