CVE-2016-3733: Moodle Improper Access Control

Published Apr 20, 2017
·
Updated

Moodle Improper Access Control

Other sources

The "restore teacher" feature in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to overwrite the course idnumber.

— GitHub

Affected Software

52 affected componentsFixes available
composer/moodle/moodle>=3.0<3.0.4
3.0.4
composer/moodle/moodle>=2.9<2.9.6
2.9.6
composer/moodle/moodle>=2.8<2.8.12
2.8.12
composer/moodle/moodle>=2.7<2.7.14
2.7.14
Moodle Moodle=2.7.0
Moodle Moodle=2.7.0-beta
Moodle Moodle=2.7.0-rc1
Moodle Moodle=2.7.0-rc2
Moodle Moodle=2.7.1
Moodle Moodle=2.7.2
Moodle Moodle=2.7.3
Moodle Moodle=2.7.4
Moodle Moodle=2.7.5
Moodle Moodle=2.7.6
Moodle Moodle=2.7.7
Moodle Moodle=2.7.8
Moodle Moodle=2.7.9
Moodle Moodle=2.7.10
Moodle Moodle=2.7.11
Moodle Moodle=2.7.12
Moodle Moodle=2.7.13
Moodle Moodle=2.8.0
Moodle Moodle=2.8.1
Moodle Moodle=2.8.2
Moodle Moodle=2.8.3
Moodle Moodle=2.8.4
Moodle Moodle=2.8.5
Moodle Moodle=2.8.6
Moodle Moodle=2.8.7
Moodle Moodle=2.8.8
Moodle Moodle=2.8.9
Moodle Moodle=2.8.10
Moodle Moodle=2.8.11
Moodle Moodle=2.9.0
Moodle Moodle=2.9.1
Moodle Moodle=2.9.2
Moodle Moodle=2.9.3
Moodle Moodle=2.9.4
Moodle Moodle=2.9.5
Moodle Moodle=3.0.0
Moodle Moodle=3.0.0-beta
Moodle Moodle=3.0.0-rc1
Moodle Moodle=3.0.0-rc2
Moodle Moodle=3.0.0-rc3
Moodle Moodle=3.0.0-rc4
Moodle Moodle=3.0.1
Moodle Moodle=3.0.2
Moodle Moodle=3.0.3
composer/moodle/moodle>=3.0, <3.0.4
3.0.4
composer/moodle/moodle>=2.9, <2.9.6
2.9.6
composer/moodle/moodle>=2.8, <2.8.12
2.8.12
composer/moodle/moodle>=2.7, <2.7.14
2.7.14

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 3.0.4
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.9.6
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.8.12
  4. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.7.14

Event History

Apr 20, 2017
CVE Published
via MITRE·09:00 PM
Data Sourced
via MITRE·09:00 PM
Description
Data Sourced
via NVD·09:59 PM
RemedyDescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via GitHub·01:12 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2016-3733?

CVE-2016-3733 is classified as a medium severity vulnerability that allows remote authenticated users to overwrite course identifiers.

2

How do I fix CVE-2016-3733?

To fix CVE-2016-3733, upgrade your Moodle installation to version 3.0.4, 2.9.6, 2.8.12, or 2.7.14.

3

Which versions of Moodle are affected by CVE-2016-3733?

CVE-2016-3733 affects Moodle versions 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, and 2.7 through 2.7.13.

4

What type of attack does CVE-2016-3733 enable?

CVE-2016-3733 enables a remote authenticated user to manipulate course identification numbers, potentially impacting course management.

5

Is CVE-2016-3733 a local or remote vulnerability?

CVE-2016-3733 is a remote vulnerability, as it requires authentication but allows attacks over the network.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203