CVE-2016-4855: XSS vulnerability in old test script
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/adodb/adodb-phpto a version that resolves this vulnerability.Fixed in 5.20.6 - Upgrade
Upgrade
ubuntu/libphp-adodbto a version that resolves this vulnerability.Fixed in 5.15-1+ - Upgrade
Upgrade
ubuntu/libphp-adodbto a version that resolves this vulnerability.Fixed in 5.20.6 - Upgrade
Upgrade
ubuntu/libphp-adodbto a version that resolves this vulnerability.Fixed in 5.20.3-1ubuntu1+ - Upgrade
Upgrade
debian/libphp-adodbto a version that resolves this vulnerability.Fixed in 5.20.14-1+deb10u1Fixed in 5.20.19-1+deb11u1Fixed in 5.21.4-1 - Upgrade
Upgrade
ADOdbto a version that resolves this vulnerability.Fixed in 5.20.6
Event History
Frequently Asked Questions
What is the severity of CVE-2016-4855?
CVE-2016-4855 is classified as a Cross-site scripting (XSS) vulnerability, which can lead to significant security risks for affected applications.
How do I fix CVE-2016-4855?
To mitigate CVE-2016-4855, upgrade ADOdb to version 5.20.6 or later.
What software is affected by CVE-2016-4855?
CVE-2016-4855 affects ADOdb versions prior to 5.20.6.
Can CVE-2016-4855 be exploited remotely?
Yes, CVE-2016-4855 can be exploited remotely, allowing attackers to inject arbitrary web scripts or HTML.
What are the potential impacts of CVE-2016-4855?
Successful exploitation of CVE-2016-4855 may lead to data theft, session hijacking, or other malicious activities against users.