CVE-2016-5172: Infoleak
The parser in Google V8, as used in Google Chrome before 53.0.2785.113, mishandles scopes, which allows remote attackers to obtain sensitive information from arbitrary memory locations via crafted JavaScript code.
Other sources
The V8 parser mishandled scopes, potentially allowing an attacker to obtain sensitive information from arbitrary memory locations via crafted JavaScript code. This vulnerability would require an attacker to be able to execute arbitrary JavaScript code in a Node.js process.
— Node.Js
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 6.9.0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2016-5172?
CVE-2016-5172 has a high severity rating due to its potential for sensitive information disclosure from memory.
How do I fix CVE-2016-5172?
To fix CVE-2016-5172, update Google Chrome to version 53.0.2785.113 or later, and ensure Node.js is updated beyond version 6.8.1.
What systems are affected by CVE-2016-5172?
CVE-2016-5172 affects Google Chrome versions prior to 53.0.2785.113, Node.js versions between 6.0.0 and 6.8.1, and Debian versions 8.0 and 9.0.
What kind of attacks can exploit CVE-2016-5172?
Attackers can exploit CVE-2016-5172 by using crafted JavaScript code to access sensitive data from memory.
Is CVE-2016-5172 still a risk in supported software versions?
No, CVE-2016-5172 is not a risk in supported software versions if they have been patched with the appropriate updates.