CVE-2016-5318: Buffer Overflow
Last updated 25 August 2025
Other sources
Stack-based buffer overflow in the TIFFVGetField function in libtiff 4.0.6 and earlier allows remote attackers to crash the application via a crafted tiff.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/tiffto a version that resolves this vulnerability.Fixed in 4.5.0-6+deb12u4Fixed in 4.7.0-3+deb13u3Fixed in 4.7.2-1
Event History
Frequently Asked Questions
What is the severity of CVE-2016-5318?
CVE-2016-5318 is classified as a high-severity vulnerability due to its potential to cause application crashes.
What systems are affected by CVE-2016-5318?
CVE-2016-5318 affects libtiff versions 4.0.6 and earlier, as well as certain versions of the tiff package on Debian.
How do I fix CVE-2016-5318?
To fix CVE-2016-5318, upgrade libtiff to version 4.2.0-1+deb11u5 or a later version.
What type of vulnerability is CVE-2016-5318?
CVE-2016-5318 is a stack-based buffer overflow vulnerability.
Who can exploit CVE-2016-5318?
CVE-2016-5318 can be exploited by remote attackers using crafted TIFF files to crash an application.