CVE-2016-5704: phpMyAdmin XSS Vulnerability
Published Jul 3, 2016
·Updated
Cross-site scripting (XSS) vulnerability in the table-structure page in phpMyAdmin 4.6.x before 4.6.3 allows remote attackers to inject arbitrary web script or HTML via vectors involving a comment.
Affected Software
8 affected componentsFixes available
composer/phpmyadmin/phpmyadmin>=4.6.0<4.6.3
4.6.3
phpMyAdmin phpMyAdmin=4.6.0
phpMyAdmin phpMyAdmin=4.6.0-alpha1
phpMyAdmin phpMyAdmin=4.6.0-rc1
phpMyAdmin phpMyAdmin=4.6.0-rc2
phpMyAdmin phpMyAdmin=4.6.1
phpMyAdmin phpMyAdmin=4.6.2
composer/phpmyadmin/phpmyadmin>=4.6.0, <4.6.3
4.6.3
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.3
Event History
Jul 3, 2016
CVE Published
via MITRE·01:00 AM
Data Sourced
via MITRE·01:00 AM
Description
Data Sourced
via NVD·01:59 AM
RemedyDescriptionSeverityWeaknessAffected Software
May 17, 2022
Advisory Published
02:37 AM
Data Sourced
via GitHub·02:37 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·02:37 AM
DescriptionSeverityAffected Software
Frequently Asked Questions
1
What is the severity of CVE-2016-5704?
CVE-2016-5704 is considered a medium severity cross-site scripting (XSS) vulnerability.
2
How do I fix CVE-2016-5704?
To fix CVE-2016-5704, upgrade phpMyAdmin to version 4.6.3 or later.
3
What software versions are affected by CVE-2016-5704?
CVE-2016-5704 affects phpMyAdmin versions 4.6.0 through 4.6.2.
4
What type of attack is CVE-2016-5704 associated with?
CVE-2016-5704 is associated with cross-site scripting (XSS) attacks.
5
Can CVE-2016-5704 lead to data compromise?
Yes, CVE-2016-5704 can potentially lead to unauthorized access and compromise of user data.