CVE-2016-5706: phpMyAdmin Denial Of Service (DOS) attack
js/getscripts.js.php in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allows remote attackers to cause a denial of service via a large array in the scripts parameter.
Other sources
phpMyAdmin Denial Of Service (DOS) attack
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.3 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.4.15.7 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.0.10.16
Event History
Frequently Asked Questions
What is the severity of CVE-2016-5706?
CVE-2016-5706 has high severity as it allows remote attackers to cause a denial of service.
How do I fix CVE-2016-5706?
To fix CVE-2016-5706, upgrade phpMyAdmin to version 4.0.10.16, 4.4.15.7 or 4.6.3 or later.
Which versions of phpMyAdmin are affected by CVE-2016-5706?
CVE-2016-5706 affects phpMyAdmin versions 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3.
What type of attack does CVE-2016-5706 involve?
CVE-2016-5706 involves remote denial of service attacks via a large array in the scripts parameter.
Is my phpMyAdmin installation at risk due to CVE-2016-5706?
If you are using an affected version of phpMyAdmin prior to the fixed versions, your installation is at risk from CVE-2016-5706.