CVE-2016-5732: phpMyAdmin XSS Vulnerability
Multiple cross-site scripting (XSS) vulnerabilities in the partition-range implementation in templates/table/structure/displaypartitions.phtml in the table-structure page in phpMyAdmin 4.6.x before 4.6.3 allow remote attackers to inject arbitrary web script or HTML via crafted table parameters.
Other sources
Multiple cross-site scripting (XSS) vulnerabilities in the partition-range implementation in templates/table/structure/displaypartitions.phtml in the table-structure page in phpMyAdmin 4.6.x before 4.6.3 allow remote attackers to inject arbitrary web script or HTML via crafted table parameters.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.3
Event History
Frequently Asked Questions
What is the severity of CVE-2016-5732?
CVE-2016-5732 is considered a moderate severity vulnerability due to its potential for cross-site scripting attacks.
How do I fix CVE-2016-5732?
To fix CVE-2016-5732, upgrade phpMyAdmin to version 4.6.3 or later.
Which versions of phpMyAdmin are affected by CVE-2016-5732?
CVE-2016-5732 affects phpMyAdmin versions 4.6.0 through 4.6.2.
What type of vulnerability is CVE-2016-5732?
CVE-2016-5732 is a cross-site scripting (XSS) vulnerability.
Can CVE-2016-5732 allow remote attacks?
Yes, CVE-2016-5732 allows remote attackers to inject malicious web scripts or HTML.