CVE-2016-6252: Integer Overflow
Integer overflow in shadow 4.2.1 allows local users to gain privileges via crafted input to newuidmap.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/shadowto a version that resolves this vulnerability.Fixed in 1:4.5-1.1Fixed in 1:4.8.1-1Fixed in 1:4.13+dfsg1-1Fixed in 1:4.13+dfsg1-2Fixed in 1:4.13+dfsg1-3 - Upgrade
Upgrade
alpine/shadowto a version that resolves this vulnerability.Fixed in 4.2.1-r7
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6252?
CVE-2016-6252 is classified as a high severity vulnerability allowing local privilege escalation.
How do I fix CVE-2016-6252?
To fix CVE-2016-6252, upgrade the shadow package to version 1:4.5-1.1 or later.
Which versions of shadow are affected by CVE-2016-6252?
All versions of shadow prior to 1:4.5-1.1, including version 4.2.1, are affected by CVE-2016-6252.
Who can exploit CVE-2016-6252?
Local users can exploit CVE-2016-6252 to gain elevated privileges through crafted input.
What is the nature of the vulnerability in CVE-2016-6252?
CVE-2016-6252 involves an integer overflow in shadow that can be exploited to escalate privileges.