CVE-2016-6302: Input Validation
An integer underflow flaw leading to a buffer over-read was found in the way OpenSSL parsed TLS session tickets. A remote attacker could use this flaw to crash a TLS server using OpenSSL if it used SHA-512 as HMAC for session tickets.
Other sources
It was found that if a ticket callback changes the HMAC digest to SHA512 the existing sanity checks are not sufficient and an attacker could perform a DoS attack with a malformed ticket.
Upstream patch:
https://github.com/openssl/openssl/commit/1bbe48ab149893a78bf99c8eb8895c928900a16f
— Red Hat
The tlsdecryptticket function in ssl/t1lib.c in OpenSSL before 1.1.0 does not consider the HMAC size during validation of the ticket length, which allows remote attackers to cause a denial of service via a ticket that is too short.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/jbcs-httpd24-apache-commons-daemonto a version that resolves this vulnerability.Fixed in 0:1.1.0-1.redhat_2.1.jbcs.el6 - Upgrade
Upgrade
redhat/jbcs-httpd24-apache-commons-daemon-jsvcto a version that resolves this vulnerability.Fixed in 1:1.1.0-1.redhat_2.jbcs.el6 - Upgrade
Upgrade
redhat/jbcs-httpd24-aprto a version that resolves this vulnerability.Fixed in 0:1.6.3-14.jbcs.el6 - Upgrade
Upgrade
redhat/jbcs-httpd24-apr-utilto a version that resolves this vulnerability.Fixed in 0:1.6.1-9.jbcs.el6 - Upgrade
Upgrade
redhat/jbcs-httpd24-httpdto a version that resolves this vulnerability.Fixed in 0:2.4.29-17.jbcs.el6 - Upgrade
Upgrade
redhat/jbcs-httpd24-nghttp2to a version that resolves this vulnerability.Fixed in 0:1.29.0-8.jbcs.el6 - Upgrade
Upgrade
redhat/jbcs-httpd24-opensslto a version that resolves this vulnerability.Fixed in 1:1.0.2n-11.jbcs.el6 - Upgrade
Upgrade
redhat/jbcs-httpd24-apache-commons-daemonto a version that resolves this vulnerability.Fixed in 0:1.1.0-1.redhat_2.1.jbcs.el7 - Upgrade
Upgrade
redhat/jbcs-httpd24-apache-commons-daemon-jsvcto a version that resolves this vulnerability.Fixed in 1:1.1.0-1.redhat_2.jbcs.el7 - Upgrade
Upgrade
redhat/jbcs-httpd24-aprto a version that resolves this vulnerability.Fixed in 0:1.6.3-14.jbcs.el7 - Upgrade
Upgrade
redhat/jbcs-httpd24-apr-utilto a version that resolves this vulnerability.Fixed in 0:1.6.1-9.jbcs.el7 - Upgrade
Upgrade
redhat/jbcs-httpd24-httpdto a version that resolves this vulnerability.Fixed in 0:2.4.29-17.jbcs.el7 - Upgrade
Upgrade
redhat/jbcs-httpd24-nghttp2to a version that resolves this vulnerability.Fixed in 0:1.29.0-8.jbcs.el7 - Upgrade
Upgrade
redhat/jbcs-httpd24-opensslto a version that resolves this vulnerability.Fixed in 1:1.0.2n-11.jbcs.el7 - Upgrade
Upgrade
redhat/opensslto a version that resolves this vulnerability.Fixed in 0:1.0.1e-48.el6_8.3 - Upgrade
Upgrade
redhat/opensslto a version that resolves this vulnerability.Fixed in 1:1.0.1e-51.el7_2.7 - Upgrade
Upgrade
debian/opensslto a version that resolves this vulnerability.Fixed in 1.1.1w-0+deb11u1Fixed in 1.1.1w-0+deb11u2Fixed in 3.0.15-1~deb12u1Fixed in 3.0.14-1~deb12u2Fixed in 3.5.0-1 - Upgrade
Upgrade
redhat/opensslto a version that resolves this vulnerability.Fixed in 1.0.1 - Upgrade
Upgrade
redhat/opensslto a version that resolves this vulnerability.Fixed in 1.0.2 - Upgrade
Upgrade
OpenSSLto a version that resolves this vulnerability.Patch 1bbe48ab149893a78bf99c8eb8895c928900a16f
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2016-6302?
CVE-2016-6302 is considered a critical severity vulnerability due to its potential to crash TLS servers.
How do I fix CVE-2016-6302?
To fix CVE-2016-6302, you should upgrade to the latest versions of the affected software packages listed in the vulnerability details.
What causes CVE-2016-6302?
CVE-2016-6302 is caused by an integer underflow flaw in OpenSSL when parsing TLS session tickets.
Is CVE-2016-6302 exploitable over the network?
Yes, CVE-2016-6302 can be exploited remotely, allowing attackers to crash servers using vulnerable versions of OpenSSL.
What versions of OpenSSL are affected by CVE-2016-6302?
CVE-2016-6302 affects various versions of OpenSSL, particularly those prior to the patched versions that address this vulnerability.