CVE-2016-6506: Medium severity Wireshark Wireshark vulnerability
epan/dissectors/packet-wsp.c in the WSP dissector in Wireshark 1.12.x before 1.12.13 and 2.x before 2.0.5 allows remote attackers to cause a denial of service (infinite loop) via a crafted packet.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.0.5-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6506?
CVE-2016-6506 has been classified as a denial of service vulnerability due to the potential for causing an infinite loop.
How do I fix CVE-2016-6506?
To fix CVE-2016-6506, upgrade Wireshark to version 1.12.13 or 2.0.5 or later.
Which versions of Wireshark are affected by CVE-2016-6506?
CVE-2016-6506 affects Wireshark versions 1.12.0 through 1.12.12 and versions 2.0.0 through 2.0.4.
What type of attack does CVE-2016-6506 enable?
CVE-2016-6506 allows remote attackers to execute a denial of service attack by sending a crafted packet.
What component of Wireshark does CVE-2016-6506 affect?
CVE-2016-6506 affects the WSP dissector within Wireshark.