CVE-2016-6508: Medium severity Wireshark Wireshark vulnerability
epan/dissectors/packet-rlc.c in the RLC dissector in Wireshark 1.12.x before 1.12.13 and 2.x before 2.0.5 uses an incorrect integer data type, which allows remote attackers to cause a denial of service (large loop) via a crafted packet.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.0.5-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6508?
CVE-2016-6508 has a medium severity level as it can lead to a denial of service via crafted packets.
How do I fix CVE-2016-6508?
To fix CVE-2016-6508, update Wireshark to version 1.12.13 or later, or to version 2.0.5 or later.
What versions of Wireshark are affected by CVE-2016-6508?
CVE-2016-6508 affects Wireshark versions 1.12.0 through 1.12.12 and versions 2.0.0 through 2.0.4.
Can CVE-2016-6508 lead to remote attacks?
Yes, CVE-2016-6508 can allow remote attackers to trigger a denial of service through specially crafted packets.
What component of Wireshark is impacted by CVE-2016-6508?
CVE-2016-6508 impacts the RLC dissector component in Wireshark.