CVE-2016-6509: Input Validation
epan/dissectors/packet-ldss.c in the LDSS dissector in Wireshark 1.12.x before 1.12.13 and 2.x before 2.0.5 mishandles conversations, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.0.5-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6509?
CVE-2016-6509 has a high severity rating due to its ability to cause a denial of service through application crashes.
How do I fix CVE-2016-6509?
To fix CVE-2016-6509, upgrade to Wireshark version 1.12.13 or 2.0.5 or later.
Which versions of Wireshark are affected by CVE-2016-6509?
CVE-2016-6509 affects Wireshark versions 1.12.0 through 1.12.12 and 2.0.0 through 2.0.4.
What kind of attack does CVE-2016-6509 allow for?
CVE-2016-6509 allows remote attackers to conduct denial of service attacks by sending crafted packets.
Is CVE-2016-6509 a local or remote vulnerability?
CVE-2016-6509 is a remote vulnerability that can be exploited over the network.