CVE-2016-6510: Buffer Overflow
Off-by-one error in epan/dissectors/packet-rlc.c in the RLC dissector in Wireshark 1.12.x before 1.12.13 and 2.x before 2.0.5 allows remote attackers to cause a denial of service (stack-based buffer overflow and application crash) via a crafted packet.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.0.5-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6510?
CVE-2016-6510 is classified as a denial-of-service vulnerability that can cause application crashes.
How do I fix CVE-2016-6510?
To fix CVE-2016-6510, update Wireshark to version 1.12.13 or later, or 2.0.5 or later.
Which versions are affected by CVE-2016-6510?
CVE-2016-6510 affects Wireshark versions 1.12.0 through 1.12.12 and 2.0.0 through 2.0.4.
Can CVE-2016-6510 be exploited remotely?
Yes, CVE-2016-6510 can be exploited remotely through crafted packets.
What type of error is present in CVE-2016-6510?
CVE-2016-6510 contains an off-by-one error in the RLC dissector of Wireshark.