CVE-2016-6608: phpMyAdmin Cross-site Scripting (XSS)
phpMyAdmin Cross-site Scripting (XSS)
Other sources
XSS issues were discovered in phpMyAdmin. This affects the database privilege check and the "Remove partitioning" functionality. Specially crafted database names can trigger the XSS attack. All 4.6.x versions (prior to 4.6.4) are affected.
— GitHub
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.4 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.6.4
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6608?
CVE-2016-6608 has a medium severity rating due to the ability to execute XSS attacks through specially crafted database names.
How do I fix CVE-2016-6608?
To fix CVE-2016-6608, upgrade phpMyAdmin to version 4.6.4 or later.
What versions of phpMyAdmin are affected by CVE-2016-6608?
All phpMyAdmin versions prior to 4.6.4, including 4.6.0, 4.6.1, 4.6.2, and 4.6.3, are affected by CVE-2016-6608.
What impact does CVE-2016-6608 have on phpMyAdmin?
CVE-2016-6608 can allow an attacker to execute XSS attacks through the database privilege check and the 'Remove partitioning' functionality.
Is there a workaround for CVE-2016-6608?
There is no specific workaround for CVE-2016-6608; upgrading to a patched version is the recommended course of action.