CVE-2016-6609: phpMyAdmin PHP code injection

Published Dec 11, 2016
·
Updated

An issue was discovered in phpMyAdmin. A specially crafted database name could be used to run arbitrary PHP commands through the array export feature. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.

Affected Software

66 affected componentsFixes available
composer/phpmyadmin/phpmyadmin>=4.0<4.0.10.17
4.0.10.17
composer/phpmyadmin/phpmyadmin>=4.4<4.4.15.8
4.4.15.8
composer/phpmyadmin/phpmyadmin>=4.6<4.6.4
4.6.4
phpMyAdmin phpMyAdmin=4.4.0
phpMyAdmin phpMyAdmin=4.4.1
phpMyAdmin phpMyAdmin=4.4.1.1
phpMyAdmin phpMyAdmin=4.4.2
phpMyAdmin phpMyAdmin=4.4.3
phpMyAdmin phpMyAdmin=4.4.4
phpMyAdmin phpMyAdmin=4.4.5
phpMyAdmin phpMyAdmin=4.4.6
phpMyAdmin phpMyAdmin=4.4.6.1
phpMyAdmin phpMyAdmin=4.4.7
phpMyAdmin phpMyAdmin=4.4.8
phpMyAdmin phpMyAdmin=4.4.9
phpMyAdmin phpMyAdmin=4.4.10
phpMyAdmin phpMyAdmin=4.4.11
phpMyAdmin phpMyAdmin=4.4.12
phpMyAdmin phpMyAdmin=4.4.13
phpMyAdmin phpMyAdmin=4.4.13.1
phpMyAdmin phpMyAdmin=4.4.14
phpMyAdmin phpMyAdmin=4.4.14.1
phpMyAdmin phpMyAdmin=4.4.15
phpMyAdmin phpMyAdmin=4.4.15.1
phpMyAdmin phpMyAdmin=4.4.15.2
phpMyAdmin phpMyAdmin=4.4.15.3
phpMyAdmin phpMyAdmin=4.4.15.4
phpMyAdmin phpMyAdmin=4.4.15.5
phpMyAdmin phpMyAdmin=4.4.15.6
phpMyAdmin phpMyAdmin=4.4.15.7
phpMyAdmin phpMyAdmin=4.0.0
phpMyAdmin phpMyAdmin=4.0.1
phpMyAdmin phpMyAdmin=4.0.2
phpMyAdmin phpMyAdmin=4.0.3
phpMyAdmin phpMyAdmin=4.0.4
phpMyAdmin phpMyAdmin=4.0.4.1
phpMyAdmin phpMyAdmin=4.0.4.2
phpMyAdmin phpMyAdmin=4.0.5
phpMyAdmin phpMyAdmin=4.0.6
phpMyAdmin phpMyAdmin=4.0.7
phpMyAdmin phpMyAdmin=4.0.8
phpMyAdmin phpMyAdmin=4.0.9
phpMyAdmin phpMyAdmin=4.0.10
phpMyAdmin phpMyAdmin=4.0.10.1
phpMyAdmin phpMyAdmin=4.0.10.2
phpMyAdmin phpMyAdmin=4.0.10.3
phpMyAdmin phpMyAdmin=4.0.10.4
phpMyAdmin phpMyAdmin=4.0.10.5
phpMyAdmin phpMyAdmin=4.0.10.6
phpMyAdmin phpMyAdmin=4.0.10.7
phpMyAdmin phpMyAdmin=4.0.10.8
phpMyAdmin phpMyAdmin=4.0.10.9
phpMyAdmin phpMyAdmin=4.0.10.10
phpMyAdmin phpMyAdmin=4.0.10.11
phpMyAdmin phpMyAdmin=4.0.10.12
phpMyAdmin phpMyAdmin=4.0.10.13
phpMyAdmin phpMyAdmin=4.0.10.14
phpMyAdmin phpMyAdmin=4.0.10.15
phpMyAdmin phpMyAdmin=4.0.10.16
phpMyAdmin phpMyAdmin=4.6.0
phpMyAdmin phpMyAdmin=4.6.1
phpMyAdmin phpMyAdmin=4.6.2
phpMyAdmin phpMyAdmin=4.6.3
composer/phpmyadmin/phpmyadmin>=4.0, <4.0.10.17
4.0.10.17
composer/phpmyadmin/phpmyadmin>=4.4, <4.4.15.8
4.4.15.8
composer/phpmyadmin/phpmyadmin>=4.6, <4.6.4
4.6.4

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/phpmyadmin/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.0.10.17
  2. Upgrade

    Upgrade composer/phpmyadmin/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.4.15.8
  3. Upgrade

    Upgrade composer/phpmyadmin/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.6.4
  4. Upgrade

    Upgrade phpMyAdmin to a version that resolves this vulnerability.

    Fixed in 4.6.4
  5. Upgrade

    Upgrade phpMyAdmin to a version that resolves this vulnerability.

    Fixed in 4.4.15.8
  6. Upgrade

    Upgrade phpMyAdmin to a version that resolves this vulnerability.

    Fixed in 4.0.10.17

Event History

Dec 11, 2016
CVE Published
via MITRE·02:00 AM
Data Sourced
via MITRE·02:00 AM
Description
Data Sourced
via NVD·02:59 AM
RemedyDescriptionSeverityWeaknessAffected Software
May 14, 2022
Advisory Published
via GitHub·03:14 AM
Data Sourced
via GitHub·03:14 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·03:14 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2016-6609?

CVE-2016-6609 has a high severity rating due to its potential for remote code execution through arbitrary PHP commands.

2

How do I fix CVE-2016-6609?

To fix CVE-2016-6609, upgrade phpMyAdmin to version 4.0.10.17, 4.4.15.8, or 4.6.4 or later.

3

Which versions of phpMyAdmin are affected by CVE-2016-6609?

Affected versions include all 4.6.x prior to 4.6.4, 4.4.x prior to 4.4.15.8, and 4.0.x prior to 4.0.10.17.

4

How can CVE-2016-6609 be exploited?

CVE-2016-6609 can be exploited by using a specially crafted database name that executes arbitrary PHP commands via the array export feature.

5

What should I do if I cannot upgrade in time due to CVE-2016-6609?

If immediate upgrade is not possible, consider implementing access controls to restrict use of phpMyAdmin while mitigating the risk.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203