CVE-2016-6613: phpMyAdmin Local file exposure through symlinks with UploadDir
An issue was discovered in phpMyAdmin. A user can specially craft a symlink on disk, to a file which phpMyAdmin is permitted to read but the user is not, which phpMyAdmin will then expose to the user. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Other sources
phpMyAdmin Local file exposure through symlinks with UploadDir
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.0.10.17 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.4.15.8 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.4 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.6.4 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.4.15.8 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.0.10.17
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6613?
CVE-2016-6613 is considered a medium severity vulnerability.
How do I fix CVE-2016-6613?
To fix CVE-2016-6613, upgrade to phpMyAdmin versions 4.6.4, 4.4.15.8, or 4.0.10.17.
Which versions of phpMyAdmin are affected by CVE-2016-6613?
CVE-2016-6613 affects phpMyAdmin versions 4.6.x prior to 4.6.4, 4.4.x prior to 4.4.15.8, and 4.0.x prior to 4.0.10.17.
What type of vulnerability is CVE-2016-6613?
CVE-2016-6613 is a symbolic link (symlink) attack vulnerability.
Can I still use older versions of phpMyAdmin if I apply patches for CVE-2016-6613?
While applying patches may mitigate the risk, it's safer to upgrade to non-vulnerable versions of phpMyAdmin.