CVE-2016-6622: phpMyAdmin DoS Vulnerability
An issue was discovered in phpMyAdmin. An unauthenticated user is able to execute a denial-of-service (DoS) attack by forcing persistent connections when phpMyAdmin is running with $cfg['AllowArbitraryServer']=true. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Other sources
An issue was discovered in phpMyAdmin. An unauthenticated user is able to execute a denial-of-service (DoS) attack by forcing persistent connections when phpMyAdmin is running with $cfg['AllowArbitraryServer']=true. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.0.10.17 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.4.15.8 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.4 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.6.4 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.4.15.8 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.0.10.17
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6622?
CVE-2016-6622 has a medium severity rating as it allows an unauthenticated user to execute denial-of-service attacks.
How do I fix CVE-2016-6622?
To fix CVE-2016-6622, upgrade phpMyAdmin to version 4.6.4 or later for 4.6.x versions and 4.4.15.8 or later for 4.4.x versions.
What versions are affected by CVE-2016-6622?
CVE-2016-6622 affects all phpMyAdmin versions prior to 4.6.4 for 4.6.x and prior to 4.4.15.8 for 4.4.x.
Can CVE-2016-6622 be exploited remotely?
Yes, CVE-2016-6622 can be exploited remotely by an unauthenticated user to perform denial-of-service attacks.
What configuration increases the risk of CVE-2016-6622?
The risk of CVE-2016-6622 increases when phpMyAdmin is running with the configuration option '$cfg['AllowArbitraryServer']=true'.