CVE-2016-6628: phpMyAdmin Reflected File Download attack
An issue was discovered in phpMyAdmin. An attacker may be able to trigger a user to download a specially crafted malicious SVG file. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Other sources
phpMyAdmin Reflected File Download attack
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.0.10.17 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.4.15.8 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.4 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.6.4 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.4.15.8 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.0.10.17
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6628?
CVE-2016-6628 has been classified as a medium severity vulnerability.
How do I fix CVE-2016-6628?
To fix CVE-2016-6628, update phpMyAdmin to version 4.6.4, 4.4.15.8, or 4.0.10.17 or later.
Which versions are affected by CVE-2016-6628?
CVE-2016-6628 affects phpMyAdmin versions 4.6.x prior to 4.6.4, 4.4.x prior to 4.4.15.8, and 4.0.x prior to 4.0.10.17.
What type of vulnerability is CVE-2016-6628?
CVE-2016-6628 is a vulnerability that allows an attacker to trigger a download of a malicious SVG file.
Is there a workaround for CVE-2016-6628 if I cannot upgrade?
There is no documented workaround for CVE-2016-6628 aside from upgrading to a patched version.