CVE-2016-6632: phpMyAdmin Denial of service (DOS) attack with dbase extension
An issue was discovered in phpMyAdmin where, under certain conditions, phpMyAdmin may not delete temporary files during the import of ESRI files. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Other sources
phpMyAdmin Denial of service (DOS) attack with dbase extension
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.0.10.17 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.4.15.8 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.4 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.6.4 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.4.15.8 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.0.10.17
Event History
Frequently Asked Questions
What is the severity of CVE-2016-6632?
CVE-2016-6632 has been classified as a medium severity vulnerability.
How do I fix CVE-2016-6632?
To fix CVE-2016-6632, update phpMyAdmin to version 4.6.4 or later, or 4.4.15.8 or later, or 4.0.10.17 or later.
What versions are affected by CVE-2016-6632?
CVE-2016-6632 affects phpMyAdmin versions 4.6.x prior to 4.6.4, 4.4.x prior to 4.4.15.8, and 4.0.x prior to 4.0.10.17.
What kind of issue does CVE-2016-6632 represent?
CVE-2016-6632 represents an issue where temporary files may not be deleted during the import of ESRI files.
Can CVE-2016-6632 be exploited remotely?
Yes, CVE-2016-6632 can potentially be exploited remotely if the affected versions of phpMyAdmin are exposed to the internet.