CVE-2016-7099: invalid wildcard certificate validation check
Fix invalid wildcard certificate validation check whereby a TLS server may be able to serve an invalid wildcard certificate for its hostname due to improper validation of . in the wildcard string.
This is a high severity defect that would allow a malicious TLS server to serve an invalid wildcard certificate for its hostname and be improperly validated by a Node.js client. This is due to a flaw in the validation of . in the wildcard name string.
Other sources
The tls.checkServerIdentity function in Node.js 0.10.x before 0.10.47, 0.12.x before 0.12.16, 4.x before 4.6.0, and 6.x before 6.7.0 does not properly handle wildcards in name fields of X.509 certificates, which allows man-in-the-middle attackers to spoof servers via a crafted certificate.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 4.6.0Fixed in 6.7.0 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 4.6.0 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 6.7.0 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 0.10.47 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 0.12.16 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 4.6.0 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 6.7.0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2016-7099?
CVE-2016-7099 is considered a moderate severity vulnerability, allowing potential man-in-the-middle attacks.
How do I fix CVE-2016-7099?
To fix CVE-2016-7099, upgrade Node.js to version 0.10.47, 0.12.16, 4.6.0 or later, or 6.7.0 or later.
What vulnerabilities does CVE-2016-7099 introduce?
CVE-2016-7099 introduces risks related to insufficient validation of wildcard characters in X.509 certificates.
Which versions of Node.js are affected by CVE-2016-7099?
CVE-2016-7099 affects Node.js versions 0.10.x before 0.10.47, 0.12.x before 0.12.16, 4.x before 4.6.0, and 6.x before 6.7.0.
Can CVE-2016-7099 be exploited remotely?
Yes, CVE-2016-7099 can be exploited remotely by attackers using crafted certificates to spoof server identities.