CVE-2016-7951: Integer Overflow
Last updated 20 October 2026
Other sources
Multiple integer overflows in X.org libXtst before 1.2.3 allow remote X servers to trigger out-of-bounds memory access operations by leveraging the lack of range checks.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/libxtstto a version that resolves this vulnerability.Fixed in 2:1.2.3-1.1Fixed in 2:1.2.5-1 - Upgrade
Upgrade
X.org libXtstto a version that resolves this vulnerability.Fixed in 1.2.3
Event History
Frequently Asked Questions
What is the severity of CVE-2016-7951?
CVE-2016-7951 is classified with a medium severity due to potential remote code execution risks.
How do I fix CVE-2016-7951?
To mitigate CVE-2016-7951, update the libXtst library to version 1.2.3 or later.
What are the affected software versions for CVE-2016-7951?
CVE-2016-7951 affects X.org libXtst versions up to and including 1.2.2, as well as Fedora 24 and 25.
What type of vulnerability is CVE-2016-7951?
CVE-2016-7951 is an integer overflow vulnerability.
Can CVE-2016-7951 be exploited remotely?
Yes, CVE-2016-7951 can be exploited by remote X servers due to the lack of proper range checks.