CVE-2016-7994: Medium severity Qemu Qemu vulnerability

Published Dec 10, 2016
·
Updated

Memory leak in the virtiogpuresourcecreate2d function in hw/display/virtio-gpu.c in QEMU (aka Quick Emulator) allows local guest OS administrators to cause a denial of service (memory consumption) via a large number of VIRTIOGPUCMDRESOURCECREATE2D commands.

Affected Software

21 affected componentsFixes available
Qemu Qemu<=2.7.1
openSUSE Leap=42.2
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/qemu to a version that resolves this vulnerability.

    Fixed in 2.8.1-r1

Event History

Dec 10, 2016
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·12:59 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·12:59 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2016-7994?

CVE-2016-7994 is considered a medium severity vulnerability due to its potential to cause denial of service through memory consumption.

2

How do I fix CVE-2016-7994?

To fix CVE-2016-7994, update QEMU to version 2.7.2 or later to mitigate the memory leak issue.

3

Who is affected by CVE-2016-7994?

CVE-2016-7994 affects local guest OS administrators using QEMU versions up to 2.7.1 and openSUSE Leap 42.2.

4

What type of attack does CVE-2016-7994 facilitate?

CVE-2016-7994 facilitates a denial of service attack by allowing the execution of multiple VIRTIO_GPU_CMD_RESOURCE_CREATE_2D commands that consume memory.

5

Which software versions are impacted by CVE-2016-7994?

CVE-2016-7994 impacts QEMU versions prior to 2.7.2 and specifically openSUSE Leap 42.2.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203