CVE-2016-9104: Integer Overflow

Published Dec 9, 2016
·
Updated

Multiple integer overflows in the (1) v9fsxattrread and (2) v9fsxattrwrite functions in hw/9pfs/9p.c in QEMU (aka Quick Emulator) allow local guest OS administrators to cause a denial of service (QEMU process crash) via a crafted offset, which triggers an out-of-bounds access.

Affected Software

23 affected componentsFixes available
Qemu Qemu<=2.7.1
Debian Debian Linux=8.0
openSUSE Leap=42.2
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1.1-r0
2.8.1.1-r0
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1
alpine/qemu<2.8.1-r1
2.8.1-r1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/qemu to a version that resolves this vulnerability.

    Fixed in 2.8.1-r1
  2. Upgrade

    Upgrade alpine/qemu to a version that resolves this vulnerability.

    Fixed in 2.8.1.1-r0

Event History

Dec 9, 2016
CVE Published
via MITRE·10:00 PM
Data Sourced
via MITRE·10:00 PM
Description
Data Sourced
via NVD·10:59 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·10:59 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2016-9104?

CVE-2016-9104 has a medium severity level as it allows local guest OS administrators to cause a denial of service.

2

How do I fix CVE-2016-9104?

To fix CVE-2016-9104, update QEMU to a version newer than 2.7.1 where the vulnerability is addressed.

3

What systems are affected by CVE-2016-9104?

CVE-2016-9104 affects QEMU versions up to 2.7.1, Debian 8.0, and openSUSE Leap 42.2.

4

What kind of attack does CVE-2016-9104 enable?

CVE-2016-9104 enables a denial of service attack by allowing a process crash through integer overflow.

5

Who can exploit CVE-2016-9104?

CVE-2016-9104 can be exploited by local guest OS administrators with the ability to craft specific offsets.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203