CVE-2016-9849: Critical severity phpMyAdmin phpMyAdmin vulnerability

Published Dec 11, 2016
·
Updated

An issue was discovered in phpMyAdmin. It is possible to bypass AllowRoot restriction ($cfg['Servers'][$i]['AllowRoot']) and deny rules for username by using Null Byte in the username. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.

Affected Software

85 affected componentsFixes available
phpMyAdmin phpMyAdmin=4.0.0
phpMyAdmin phpMyAdmin=4.0.1
phpMyAdmin phpMyAdmin=4.0.2
phpMyAdmin phpMyAdmin=4.0.3
phpMyAdmin phpMyAdmin=4.0.4
phpMyAdmin phpMyAdmin=4.0.4.1
phpMyAdmin phpMyAdmin=4.0.4.2
phpMyAdmin phpMyAdmin=4.0.5
phpMyAdmin phpMyAdmin=4.0.6
phpMyAdmin phpMyAdmin=4.0.7
phpMyAdmin phpMyAdmin=4.0.8
phpMyAdmin phpMyAdmin=4.0.9
phpMyAdmin phpMyAdmin=4.0.10
phpMyAdmin phpMyAdmin=4.0.10.1
phpMyAdmin phpMyAdmin=4.0.10.2
phpMyAdmin phpMyAdmin=4.0.10.3
phpMyAdmin phpMyAdmin=4.0.10.4
phpMyAdmin phpMyAdmin=4.0.10.5
phpMyAdmin phpMyAdmin=4.0.10.6
phpMyAdmin phpMyAdmin=4.0.10.7
phpMyAdmin phpMyAdmin=4.0.10.8
phpMyAdmin phpMyAdmin=4.0.10.9
phpMyAdmin phpMyAdmin=4.0.10.10
phpMyAdmin phpMyAdmin=4.0.10.11
phpMyAdmin phpMyAdmin=4.0.10.12
phpMyAdmin phpMyAdmin=4.0.10.13
phpMyAdmin phpMyAdmin=4.0.10.14
phpMyAdmin phpMyAdmin=4.0.10.15
phpMyAdmin phpMyAdmin=4.0.10.16
phpMyAdmin phpMyAdmin=4.0.10.17
phpMyAdmin phpMyAdmin=4.6.0
phpMyAdmin phpMyAdmin=4.6.1
phpMyAdmin phpMyAdmin=4.6.2
phpMyAdmin phpMyAdmin=4.6.3
phpMyAdmin phpMyAdmin=4.6.4
phpMyAdmin phpMyAdmin=4.4.0
phpMyAdmin phpMyAdmin=4.4.1
phpMyAdmin phpMyAdmin=4.4.1.1
phpMyAdmin phpMyAdmin=4.4.2
phpMyAdmin phpMyAdmin=4.4.3
phpMyAdmin phpMyAdmin=4.4.4
phpMyAdmin phpMyAdmin=4.4.5
phpMyAdmin phpMyAdmin=4.4.6
phpMyAdmin phpMyAdmin=4.4.6.1
phpMyAdmin phpMyAdmin=4.4.7
phpMyAdmin phpMyAdmin=4.4.8
phpMyAdmin phpMyAdmin=4.4.9
phpMyAdmin phpMyAdmin=4.4.10
phpMyAdmin phpMyAdmin=4.4.11
phpMyAdmin phpMyAdmin=4.4.12
phpMyAdmin phpMyAdmin=4.4.13
phpMyAdmin phpMyAdmin=4.4.13.1
phpMyAdmin phpMyAdmin=4.4.14
phpMyAdmin phpMyAdmin=4.4.14.1
phpMyAdmin phpMyAdmin=4.4.15
phpMyAdmin phpMyAdmin=4.4.15.1
phpMyAdmin phpMyAdmin=4.4.15.2
phpMyAdmin phpMyAdmin=4.4.15.3
phpMyAdmin phpMyAdmin=4.4.15.4
phpMyAdmin phpMyAdmin=4.4.15.5
phpMyAdmin phpMyAdmin=4.4.15.6
phpMyAdmin phpMyAdmin=4.4.15.7
phpMyAdmin phpMyAdmin=4.4.15.8
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.4.15.9-r0
4.4.15.9-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0
alpine/phpmyadmin<4.6.5.2-r0
4.6.5.2-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.6.5.2-r0
  2. Upgrade

    Upgrade alpine/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.4.15.9-r0
  3. Upgrade

    Upgrade phpMyAdmin to a version that resolves this vulnerability.

    Fixed in 4.6.5
  4. Upgrade

    Upgrade phpMyAdmin to a version that resolves this vulnerability.

    Fixed in 4.4.15.9
  5. Upgrade

    Upgrade phpMyAdmin to a version that resolves this vulnerability.

    Fixed in 4.0.10.18

Event History

Dec 11, 2016
CVE Published
via MITRE·02:00 AM
Data Sourced
via MITRE·02:00 AM
Description
Data Sourced
via NVD·02:59 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:59 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2016-9849?

CVE-2016-9849 has a severity rating that indicates a significant risk due to potential root access bypass.

2

How do I fix CVE-2016-9849?

To fix CVE-2016-9849, upgrade phpMyAdmin to version 4.6.5 or later, or to 4.4.15.9 and 4.0.10.18 or later.

3

Which versions of phpMyAdmin are affected by CVE-2016-9849?

CVE-2016-9849 affects phpMyAdmin versions 4.6.x prior to 4.6.5, 4.4.x prior to 4.4.15.9, and 4.0.x prior to 4.0.10.18.

4

What is the main issue caused by CVE-2016-9849?

The main issue of CVE-2016-9849 is the ability to bypass AllowRoot restrictions using a Null Byte in the username.

5

Can CVE-2016-9849 be exploited by attackers?

Yes, attackers can exploit CVE-2016-9849 to gain unauthorized root access to the database.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203