CVE-2017-0861: Use After Free
Last updated 29 November 2024
Other sources
Use-after-free vulnerability in the sndpcminfo function in the ALSA subsystem in the Linux kernel allows attackers to gain privileges via unspecified vectors.
— Launchpad
Use-after-free vulnerability in the sndpcminfo() function in the ALSA subsystem in the Linux kernel allows attackers to induce a kernel memory corruption and possibly crash or lock up a system. Due to the nature of the flaw, a privilege escalation cannot be fully ruled out, although we believe it is unlikely.
References:
http://lists.alioth.debian.org/pipermail/secure-testing-commits/2017-December/059967.html
https://source.android.com/security/bulletin/pixel/2017-11-01#kernel-components
An upstream patch:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=362bca57f5d78220f8b5907b875961af9436e229
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 4.15 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Patch 362bca57f5d78220f8b5907b875961af9436e229
Event History
Frequently Asked Questions
What is the severity of CVE-2017-0861?
CVE-2017-0861 is classified as a medium severity vulnerability due to its potential privilege escalation capability.
How do I fix CVE-2017-0861?
To fix CVE-2017-0861, update the affected Linux kernel to at least version 4.15 or apply relevant patches from your distribution.
Which systems are affected by CVE-2017-0861?
CVE-2017-0861 affects various Linux-based systems, including Google Android and specific versions of the Red Hat and Debian kernel.
What is the nature of CVE-2017-0861?
CVE-2017-0861 is a use-after-free vulnerability in the snd_pcm_info function in the ALSA subsystem of the Linux kernel.
Can CVE-2017-0861 be exploited remotely?
The specific vectors for exploiting CVE-2017-0861 are unspecified, so its potential for remote exploitation may vary based on the system configuration.