CVE-2017-1000015: phpMyAdmin CSS Injection Vulnerability

Published Jul 13, 2017
·
Updated

phpMyAdmin 4.0, 4.4, and 4.6 are vulnerable to a CSS injection attack through crafted cookie parameters

Affected Software

76 affected componentsFixes available
composer/phpmyadmin/phpmyadmin>=4.0.0<4.0.10.19
4.0.10.19
composer/phpmyadmin/phpmyadmin>=4.4.0<4.4.15.10
4.4.15.10
composer/phpmyadmin/phpmyadmin>=4.6.0<4.6.6
4.6.6
phpMyAdmin phpMyAdmin=4.0.0
phpMyAdmin phpMyAdmin=4.0.0-rc2
phpMyAdmin phpMyAdmin=4.0.0-rc3
phpMyAdmin phpMyAdmin=4.0.1
phpMyAdmin phpMyAdmin=4.0.2
phpMyAdmin phpMyAdmin=4.0.3
phpMyAdmin phpMyAdmin=4.0.4
phpMyAdmin phpMyAdmin=4.0.4.1
phpMyAdmin phpMyAdmin=4.0.4.2
phpMyAdmin phpMyAdmin=4.0.5
phpMyAdmin phpMyAdmin=4.0.6
phpMyAdmin phpMyAdmin=4.0.7
phpMyAdmin phpMyAdmin=4.0.8
phpMyAdmin phpMyAdmin=4.0.9
phpMyAdmin phpMyAdmin=4.0.10
phpMyAdmin phpMyAdmin=4.0.10.1
phpMyAdmin phpMyAdmin=4.0.10.2
phpMyAdmin phpMyAdmin=4.0.10.3
phpMyAdmin phpMyAdmin=4.0.10.4
phpMyAdmin phpMyAdmin=4.0.10.5
phpMyAdmin phpMyAdmin=4.0.10.6
phpMyAdmin phpMyAdmin=4.0.10.7
phpMyAdmin phpMyAdmin=4.0.10.8
phpMyAdmin phpMyAdmin=4.0.10.9
phpMyAdmin phpMyAdmin=4.0.10.10
phpMyAdmin phpMyAdmin=4.0.10.11
phpMyAdmin phpMyAdmin=4.0.10.12
phpMyAdmin phpMyAdmin=4.0.10.13
phpMyAdmin phpMyAdmin=4.0.10.14
phpMyAdmin phpMyAdmin=4.0.10.15
phpMyAdmin phpMyAdmin=4.0.10.16
phpMyAdmin phpMyAdmin=4.0.10.17
phpMyAdmin phpMyAdmin=4.0.10.18
phpMyAdmin phpMyAdmin=4.4.0
phpMyAdmin phpMyAdmin=4.4.1
phpMyAdmin phpMyAdmin=4.4.1.1
phpMyAdmin phpMyAdmin=4.4.2
phpMyAdmin phpMyAdmin=4.4.3
phpMyAdmin phpMyAdmin=4.4.4
phpMyAdmin phpMyAdmin=4.4.5
phpMyAdmin phpMyAdmin=4.4.6
phpMyAdmin phpMyAdmin=4.4.6.1
phpMyAdmin phpMyAdmin=4.4.7
phpMyAdmin phpMyAdmin=4.4.8
phpMyAdmin phpMyAdmin=4.4.9
phpMyAdmin phpMyAdmin=4.4.10
phpMyAdmin phpMyAdmin=4.4.11
phpMyAdmin phpMyAdmin=4.4.12
phpMyAdmin phpMyAdmin=4.4.13
phpMyAdmin phpMyAdmin=4.4.13.1
phpMyAdmin phpMyAdmin=4.4.14.1
phpMyAdmin phpMyAdmin=4.4.15
phpMyAdmin phpMyAdmin=4.4.15.1
phpMyAdmin phpMyAdmin=4.4.15.2
phpMyAdmin phpMyAdmin=4.4.15.3
phpMyAdmin phpMyAdmin=4.4.15.4
phpMyAdmin phpMyAdmin=4.4.15.5
phpMyAdmin phpMyAdmin=4.4.15.6
phpMyAdmin phpMyAdmin=4.4.15.7
phpMyAdmin phpMyAdmin=4.4.15.8
phpMyAdmin phpMyAdmin=4.4.15.9
phpMyAdmin phpMyAdmin=4.6.0
phpMyAdmin phpMyAdmin=4.6.0-alpha1
phpMyAdmin phpMyAdmin=4.6.0-rc1
phpMyAdmin phpMyAdmin=4.6.0-rc2
phpMyAdmin phpMyAdmin=4.6.1
phpMyAdmin phpMyAdmin=4.6.2
phpMyAdmin phpMyAdmin=4.6.3
phpMyAdmin phpMyAdmin=4.6.4
phpMyAdmin phpMyAdmin=4.6.5
composer/phpmyadmin/phpmyadmin>=4.0.0, <4.0.10.19
4.0.10.19
composer/phpmyadmin/phpmyadmin>=4.4.0, <4.4.15.10
4.4.15.10
composer/phpmyadmin/phpmyadmin>=4.6.0, <4.6.6
4.6.6

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/phpmyadmin/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.0.10.19
  2. Upgrade

    Upgrade composer/phpmyadmin/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.4.15.10
  3. Upgrade

    Upgrade composer/phpmyadmin/phpmyadmin to a version that resolves this vulnerability.

    Fixed in 4.6.6

Event History

Jul 13, 2017
CVE Published
via MITRE·08:00 PM
Data Sourced
via MITRE·08:00 PM
Description
Jul 17, 2017
Data Sourced
via NVD·01:18 PM
DescriptionSeverityWeaknessAffected Software
May 14, 2022
Advisory Published
01:18 AM
Data Sourced
via GitHub·01:18 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·01:18 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2017-1000015?

CVE-2017-1000015 is classified as a medium severity vulnerability.

2

How do I fix CVE-2017-1000015?

To fix CVE-2017-1000015, upgrade phpMyAdmin to the latest version that addresses this vulnerability.

3

Which versions of phpMyAdmin are affected by CVE-2017-1000015?

CVE-2017-1000015 affects phpMyAdmin versions 4.0, 4.4, and 4.6.

4

What type of attack does CVE-2017-1000015 allow?

CVE-2017-1000015 allows for a CSS injection attack through crafted cookie parameters.

5

Is CVE-2017-1000015 still a concern for outdated phpMyAdmin installations?

Yes, CVE-2017-1000015 remains a concern for any outdated installations of phpMyAdmin that have not been patched.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203