CVE-2017-1000016: phpMyAdmin Cookie attribute injection attack
A weakness was discovered where an attacker can inject arbitrary values in to the browser cookies. This is a re-issue of an incomplete fix from PMASA-2016-18.
Other sources
phpMyAdmin Cookie attribute injection attack
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.6
Event History
Frequently Asked Questions
What is the severity of CVE-2017-1000016?
The severity of CVE-2017-1000016 is classified as moderate due to the potential for attackers to inject arbitrary values into browser cookies.
How do I fix CVE-2017-1000016?
To fix CVE-2017-1000016, upgrade to phpMyAdmin version 4.6.6 or later.
Which versions of phpMyAdmin are affected by CVE-2017-1000016?
CVE-2017-1000016 affects phpMyAdmin versions 4.6.0 to 4.6.5.2.
What kind of attacks can exploit CVE-2017-1000016?
CVE-2017-1000016 can be exploited by attackers to manipulate browser cookies, potentially leading to session hijacking or data manipulation.
Is CVE-2017-1000016 a newly discovered vulnerability?
CVE-2017-1000016 is a re-issue of an earlier vulnerability with an incomplete fix that was originally addressed in PMASA-2016-18.