CVE-2017-1000017: phpMyAdmin SSRF in replication
phpMyAdmin 4.0, 4.4 and 4.6 are vulnerable to a weakness where a user with appropriate permissions is able to connect to an arbitrary MySQL server
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.0.10.19 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.4.15.10 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.6
Event History
Frequently Asked Questions
What is the severity of CVE-2017-1000017?
CVE-2017-1000017 is considered a medium severity vulnerability.
How do I fix CVE-2017-1000017?
To fix CVE-2017-1000017, upgrade phpMyAdmin to version 4.0.10.19, 4.4.15.10, or 4.6.6.
What versions of phpMyAdmin are affected by CVE-2017-1000017?
phpMyAdmin versions 4.0.x, 4.4.x, and 4.6.x prior to their respective patched versions are affected.
What type of vulnerability is CVE-2017-1000017?
CVE-2017-1000017 is a permissions vulnerability that allows unauthorized MySQL connections.
Who can exploit CVE-2017-1000017?
A user with appropriate permissions can exploit CVE-2017-1000017 to connect to arbitrary MySQL servers.