CVE-2017-1000018: phpMyAdmin DoS Vulnerability
phpMyAdmin 4.0, 4.4., and 4.6 are vulnerable to a DOS attack in the replication status by using a specially crafted table name
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.0.10.19 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.4.15.10 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.6.6
Event History
Frequently Asked Questions
What is the severity of CVE-2017-1000018?
CVE-2017-1000018 is classified as a denial-of-service vulnerability.
How do I fix CVE-2017-1000018?
To fix CVE-2017-1000018, upgrade phpMyAdmin to version 4.0.10.19, 4.4.15.10, or 4.6.6 or later.
Which versions of phpMyAdmin are affected by CVE-2017-1000018?
CVE-2017-1000018 affects phpMyAdmin versions 4.0.x, 4.4.x, and 4.6.x prior to the specified remedial versions.
What type of attack can be executed using CVE-2017-1000018?
CVE-2017-1000018 can be exploited to perform a denial-of-service attack by using a specially crafted table name.
What protocols are impacted by CVE-2017-1000018?
CVE-2017-1000018 impacts the replication status feature of phpMyAdmin.