CVE-2017-1000407: High severity redhat Virtualization Host vulnerability

Published Dec 4, 2017
·
Updated

Last updated 29 November 2024

Other sources

Linux kernel built with the KVM virtualization(CONFIGKVM) support for the Intel processor family(CONFIGKVMINTEL), is vulnerable to a DoS issue. It could occur if a guest was to flood the I/O port 0x80 with write requests.

A guest user could use this flaw to crash the host kernel resulting in DoS.

Upstream patch -------------- -> https://www.spinics.net/lists/kvm/msg159809.html

Reference: ---------- -> http://www.openwall.com/lists/oss-security/2017/12/04/2

— Red Hat

The Linux Kernel 2.6.32 and later are affected by a denial of service, by flooding the diagnostic port 0x80 an exception can be triggered leading to a kernel panic.

— Launchpad

Affected Software

18 affected componentsFixes available
redhat Virtualization Host=4.0
redhat Enterprise Linux Desktop=7.0
redhat Enterprise Linux Server=7.0
redhat Enterprise Linux Server Aus=7.6
redhat Enterprise Linux Server Eus=7.6
redhat Enterprise Linux Server Tus=7.6
redhat Enterprise Linux Workstation=7.0
Linux Linux kernel>=2.6.32<4.15
Linux Linux kernel=4.15-rc1
Linux Linux kernel=4.15-rc2
Debian Debian Linux=7.0
Debian Debian Linux=8.0
Debian Debian Linux=9.0
Canonical Ubuntu Linux=12.04
Canonical Ubuntu Linux=14.04
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=17.10
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Dec 4, 2017
Data Sourced
via Red Hat·09:29 AM
DescriptionSeverityAffected Software
Dec 11, 2017
CVE Published
via MITRE·09:00 PM
Data Sourced
via MITRE·09:00 PM
Description

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2017-1000407?

CVE-2017-1000407 is considered to have a high severity due to its potential to cause a denial of service.

2

How do I fix CVE-2017-1000407?

To fix CVE-2017-1000407, it is recommended to upgrade to patched kernel versions including 5.10.223-1 or later.

3

Which systems are affected by CVE-2017-1000407?

CVE-2017-1000407 affects various Linux distributions including Red Hat Enterprise Linux, Debian, and Ubuntu systems.

4

What type of attack does CVE-2017-1000407 involve?

CVE-2017-1000407 involves a denial of service attack that floods an I/O port with write requests.

5

When was CVE-2017-1000407 reported?

CVE-2017-1000407 was reported on December 4, 2017.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203