CVE-2017-1000488: Inline JS XSS vulnerability in Mautic
Impact
Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.
Patches Upgrade to 2.12.0 or later.
Workarounds None
References https://github.com/mautic/mautic/releases/tag/2.12.0
For more information If you have any questions or comments about this advisory: Email us at security@mautic.org
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/mautic/coreto a version that resolves this vulnerability.Fixed in 2.12.0 - Upgrade
Upgrade
Mauticto a version that resolves this vulnerability.Fixed in 2.12.0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-1000488?
The severity of CVE-2017-1000488 is medium with a CVSS score of 6.1.
How does CVE-2017-1000488 affect Mautic?
CVE-2017-1000488 affects Mautic versions 2.1.0 to 2.11.0.
What is the impact of CVE-2017-1000488?
CVE-2017-1000488 allows an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.
How can I fix CVE-2017-1000488?
To fix CVE-2017-1000488, you should upgrade to Mautic version 2.12.0 or later.
Where can I find more information about CVE-2017-1000488?
You can find more information about CVE-2017-1000488 at the following link: [https://github.com/mautic/mautic/releases/tag/2.12.0](https://github.com/mautic/mautic/releases/tag/2.12.0)