CVE-2017-1000489: Disabled users able to log in with third party SSO plugin

Published Jan 3, 2018
·
Updated

Impact Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address

Patches Upgrade to 2.12.0 or later.

Workarounds None.

For more information If you have any questions or comments about this advisory: Email us at security@mautic.org

Other sources

Disabled users able to log in with third party SSO plugin

— Packagist

Affected Software

28 affected componentsFixes available
composer/mautic/core>=2.0.0<2.12.0
2.12.0
Acquia Mautic=2.0.0
Acquia Mautic=2.0.1
Acquia Mautic=2.1.0
Acquia Mautic=2.1.1
Acquia Mautic=2.2.0
Acquia Mautic=2.2.1
Acquia Mautic=2.3.0
Acquia Mautic=2.4.0
Acquia Mautic=2.5.0
Acquia Mautic=2.5.1
Acquia Mautic=2.6.0
Acquia Mautic=2.6.1
Acquia Mautic=2.7.0
Acquia Mautic=2.7.1
Acquia Mautic=2.8.0
Acquia Mautic=2.8.1
Acquia Mautic=2.8.2
Acquia Mautic=2.9.0-beta
Acquia Mautic=2.9.1
Acquia Mautic=2.10.0-beta
Acquia Mautic=2.10.1
Acquia Mautic=2.11.0-beta
Mautic Mautic=2.9.0
Mautic Mautic=2.9.2
Mautic Mautic=2.10.0
Mautic Mautic=2.11.0
composer/mautic/core>=2.0.0, <2.12.0
2.12.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/mautic/core to a version that resolves this vulnerability.

    Fixed in 2.12.0
  2. Upgrade

    Upgrade Mautic to a version that resolves this vulnerability.

    Fixed in 2.12.0

Event History

Jan 3, 2018
CVE Published
via MITRE·05:00 PM
Data Sourced
via MITRE·05:00 PM
Description
Data Sourced
via NVD·05:29 PM
DescriptionSeverityWeaknessAffected Software
Jan 19, 2021
Advisory Published
09:16 PM
Data Sourced
via GitHub·09:16 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·09:16 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2017-1000489 vulnerability?

CVE-2017-1000489 is a vulnerability in Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed that could allow a disabled user to still login using an email address.

2

How severe is CVE-2017-1000489?

CVE-2017-1000489 has a severity score of 8.1 (high severity).

3

How can I fix CVE-2017-1000489?

To fix CVE-2017-1000489, you should upgrade to Mautic version 2.12.0 or later.

4

Are there any workarounds for CVE-2017-1000489?

No, there are no known workarounds for CVE-2017-1000489.

5

Where can I find more information about CVE-2017-1000489?

You can find more information about CVE-2017-1000489 on the GitHub Security Advisory and NIST NVD websites.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203